Erreur awstats

Si vous avez suivi un de mes précédents posts sur la mise en place de Geoip dans awstats ici . J’utilisais la version 1.24 du fichier PurePerl.pm . Depuis ma migration j’ai installé la version 1.25 disponible sur le site de maxmind.
Malheureusement suite à son installation j’obtiens l’erreur suivante:

  1. /*
  2. Error: Plugin init for plugin ‘geoip’ failed with return code: Undefined subroutine &Geo::IP::GEOIP_STANDARD called at /usr/share/awstats/plugins/geoip.pm line 71.
  3. (A module required by plugin might be missing).
  4. */

Afin de corriger ce problème on édite /usr/share/awstats/plugins/geoip.pm .

Modifier toutes les lignes commençant par

  1. /*
  2. $type=‘geoip’
  3. */

Par

  1. /*
  2. $type=‘geoippureperl’
  3. */

On peut à nouveau avoir une page de stats propre 🙂

Related posts

Leave a Comment