Upgrade debian lenny vers squeeze

Ce matin cherchant un truc pour me dégourdir les doigts je décide de faire une petite mis à jour de ma debian lenny vers la squeeze. La procédure d’upgrade est relativement simple.  On modifie notre fichier source.list

deb http://ftp.fr.debian.org/debian/ squeeze main non-free
deb-src http://ftp.fr.debian.org/debian/ squeeze main non-free
deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main

Il faut par la suite lancer

apt-get update
apt-get upgrade
apt-get dist-upgrade

Des problèmes peuvent être rencontrés avec udev :

Since release 150, udev requires that support for 
the CONFIG_SYSFS_DEPRECATEDfeature is disabled in the running kernel.
Please upgrade your kernel before or while upgrading udev.
AT YOUR OWN RISK, you can force the installation of this version of udevWHICH 
DOES NOT WORK WITH YOUR RUNNING KERNEL AND WILL BREAK YOUR SYSTEMAT THE NEXT 
REBOOT by creating the /etc/udev/kernel-upgrade file.There is always a safer way to upgrade, 
do not try this unless youunderstand what you are doing!dpkg : 
erreur de traitement de /var/cache/apt/archives/udev_151-3_i386.deb (--unpack) 
:le sous-processus nouveau script pre-installation a retourné une erreur
 de sortie d'état 1Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/udev_151-3_i386.debE: Sub-process /usr/bin/dpkg 
returned an error code (1)

Si vous avez ce message installer un noyau plus récent personnellement je suis passé en 2.6.30

apt-cache search linux-imageapt-get install votre-image-en-fonction-de-votre-archi

Certains problèmes peuvent apparaître à ce niveau , Si l’installation ne s’effectue pas se rendre :

cd /var/cache/apt/archives
dpkg -i votre-image-en-fonction-de-votre-archi

Cela va nettement mieux 🙂 on respire et on reboot pour conclure un petit upgrade 🙂 Voili Voilou

Voir aussi le lien suivant

Related posts

Leave a Comment